Arrêt de la passerelle Free Radio Network

La passerelle AlterFRN est pleinement opérationnelle ainsi je demande aux utilisateurs de Free Radio Network de modifier le port du serveur dans leur client. AlterFRN est sur le port 10025, l’adresse du serveur ne change pas et c’est la seule chose à faire.

Je laisse toutefois la passerelle FRN normale en fonction jusqu’à la fin du mois pour ceux qui ne suivent pas.

L’utilisation de AlterFRN à la place de FRN me permet d’économiser une part non négligeable des ressources sur le serveur. Le serveur et le client sont des programmes natif linux. Je n’ai donc plus besoin de Wine pour que ça fonctionne.

L’autre atout et de ne pas être dépendant du system manager au Pays Bas qui ne fonctionne plus vraiment bien. L’autre system manager en Allemagne ne fonctionne pas mieux.

J’ai migré les comptes vers AlterFRN, je ne pense pas en avoir oublié. J’en ai effacé que je n’ai pas vu se connecter depuis des lustres. Normalement si je n’ai pas fait de fautes de frappe ça devrait être bon pour tout le monde.

Nouvelle passerelle AlterFRN

J’ai décidé de mettre ne place une passerelle AlterFRN. AlterFRN est un logiciel alternatif à Free Radio Network. Le serveur est assez simple à mettre en place, le client un peu moins. Le principale avantage est qu’il est totalement indépendant de ce qui se passe au Pays Bas et de ce putain de System Manager. Un autre avantage est qu’il existe des clients natifs pour Linux et Raspberry et là je sens que ça va en intéresser plus d’un.

On peu se connecter avec le client officiel donc pour les utilisateurs qui utilisent déjà se programme rien ne change à part les méthodes d’authentification.

Mais attention c’est pas facile, il n’y a pas de GUI. Toute se trouve dans un fichier de config assez obscure et la documentation est en russe. Il faut modifier ce fichier et lancer le client. Si ça marche pas il faut l’arrêter et recommencer. C’est un peu une galère.

La passerelle est en test, le serveur aussi et pour l’instant je n’expliquerai pas comment l’utiliser. Seul mon relais est dessus.

Mises à jour du 9 février ~ 22:45

==> Nouvelle révision des paquets :
 core/gnupg 2.2.4-1 1 -> 2
 core/libtirpc 1.0.2-1 1 -> 3
 core/libtool 2.4.6+40+g6ca5e224-2 2 -> 4
 extra/ffmpeg 1:3.4.1-3 3 -> 4
 extra/freetype2 2.9-1 1 -> 2
 extra/fribidi 0.19.7-1 1 -> 2
 extra/gst-plugins-bad 1.12.4-2 2 -> 3
 extra/libcups 2.2.6-1 1 -> 4
 extra/libice 1.0.9-1 1 -> 2
 extra/libxau 1.0.8-2 2 -> 3
 extra/libxdamage 1.1.4-2 2 -> 3
 extra/libxfixes 5.0.3-1 1 -> 2
 extra/libxrandr 1.5.1-1 1 -> 2
 extra/mesa 17.3.3-1 1 -> 2
 extra/p7zip 16.02-3 3 -> 4
 community/mediastreamer 2.16.1-2 2 -> 3
 community/teamspeak3 3.1.8-1 1 -> 2
 community/wxpython 3.0.2.0-6 6 -> 7
 multilib/lib32-attr 2.4.47-1 1 -> 2

==> Mise à jour des logiciels (nouvelle version) :
 core/bash 4.4.012-2 -> 4.4.018-1
 core/btrfs-progs 4.14-2 -> 4.14.1-1
 core/curl 7.57.0-1 -> 7.58.0-1
 core/gcc 7.2.1+20180116-1 -> 7.3.0-1
 core/gcc-libs 7.2.1+20180116-1 -> 7.3.0-1
 core/gzip 1.8-2 -> 1.9-1
 core/iana-etc 20170824-1 -> 20180131-1
 core/iproute2 4.14.1-2 -> 4.15.0-1
 core/lib32-gcc-libs 7.2.1+20180116-1 -> 7.3.0-1
 core/libnftnl 1.0.8-1 -> 1.0.9-1
 core/libsystemd 236.81-1 -> 237.0-2
 core/linux-lts 4.9.78-1 -> 4.14.18-1
 core/linux-lts-headers 4.9.78-1 -> 4.14.18-1
 core/man-db 2.7.6.1-3 -> 2.8.0-1
 core/man-pages 4.14-1 -> 4.15-1
 core/nano 2.9.2-1 -> 2.9.3-1
 core/pacman-mirrorlist 20171203-1 -> 20180203-1
 core/systemd 236.81-1 -> 237.0-2
 core/systemd-sysvcompat 236.81-1 -> 237.0-2
 extra/bind 9.11.2.P1-1 -> 9.12.0-1
 extra/bind-tools 9.11.2.P1-1 -> 9.12.0-1
 extra/cantarell-fonts 1:0.0.25-3 -> 1:0.100-1
 extra/chromium 64.0.3282.119-1 -> 64.0.3282.140-2
 extra/dbus-glib 0.108-1 -> 0.110-1
 extra/ethtool 1:4.13-1 -> 1:4.15-1
 extra/geoip-database 20180102-1 -> 20180206-1
 extra/gnome-themes-standard 3.22.3+13+ga993fdc0-1 -> 3.22.3+16+gc092fc89-1
 -> 3.22.26+161+g60750b3ffd-extra/gtk3 3.22.26+47+g3a1a7135a2-3
 -> 3.22.26+161+g60750b3ffd-extra/gtk-update-icon-cache 3.22.26+47+g3a1a7135a2-3
 extra/gvfs 1.34.1+11+gad63dfb7-1 -> 1.34.2-1
 extra/harfbuzz 1.7.4-1 -> 1.7.5-1
 extra/harfbuzz-icu 1.7.4-1 -> 1.7.5-1
 extra/htop 2.0.2-2 -> 2.1.0-1
 extra/libevdev 1.5.7-1 -> 1.5.8-1
 extra/librsvg 2:2.42.1-1 -> 2:2.42.2-1
 extra/libvpx 1.6.1-1 -> 1.7.0-1
 extra/php 7.2.1-3 -> 7.2.2-1
 extra/php-apache 7.2.1-3 -> 7.2.2-1
 extra/php-gd 7.2.1-3 -> 7.2.2-1
 extra/php-intl 7.2.1-3 -> 7.2.2-1
 extra/python-setuptools 1:38.4.0-1 -> 1:38.5.1-1
 extra/re2 20180101-1 -> 20180201-1
 extra/rsync 3.1.3pre1-1 -> 3.1.3-1
 extra/transmission-cli 2.92-8 -> 2.93-1
 extra/transmission-gtk 2.92-8 -> 2.93-1
 extra/unison 2.48.4-2 -> 2.48.15-3
 extra/v4l-utils 1.12.5-1 -> 1.14.1-1
 extra/vim 8.0.1415-2 -> 8.0.1476-1
 extra/vim-runtime 8.0.1415-2 -> 8.0.1476-1
 extra/vte3 0.50.2-1 -> 0.50.2+6+g7fe155b9-1
 extra/vte-common 0.50.2-1 -> 0.50.2+6+g7fe155b9-1
 extra/vulkan-icd-loader 1.0.61.1-1 -> 1.0.68.0-1
 extra/xkeyboard-config 2.22-1 -> 2.23.1-2
 extra/xorg-server 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 extra/xorg-server-common 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 extra/xorg-server-devel 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 extra/xorg-server-xdmx 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 extra/xorg-server-xephyr 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 extra/xorg-server-xnest 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 extra/xorg-server-xvfb 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 extra/xorg-server-xwayland 1.19.6-2 -> 1.19.6+13+gd0d1a694f-1
 multilib/lib32-systemd 236.81-1 -> 237.0-1
 aur/adminer 4.5.0-1 -> 4.6.0-1

==> Nouveau paquet :
 extra/ilmbase 2.2.0-2 (requis par openexr)
 (requis par gst-plugins-badextra/libbs2b 3.1.0-6
 (requis par gst-plugins-badextra/openexr 2.2.0-3
 extra/wxgtk3 3.0.3.1-11 (requis par wxpython)

Mises à jour du 27 janvier 2017 ~ 11:00

Bon quelques soucis après ces mises à jour. Le client TS3 ne démarre plus. Il me casse les pieds avec OpenGL. Je cherche une solution.

Solution trouvé: Installer virtualgl puis vglrun -d $DISPLAY teamspeak3

==> Nouvelle révision des paquets :
 core/gawk 4.2.0-2 2 -> 3
 core/glibc 2.26-10 10 -> 11
 core/lib32-glibc 2.26-10 10 -> 11
 core/libsasl 2.1.26-11 11 -> 12
 core/libseccomp 2.3.2-1 1 -> 2
 core/man-db 2.7.6.1-2 2 -> 3
 core/perl 5.26.1-1 1 -> 2
 extra/apr-util 1.6.1-1 1 -> 2
 extra/avahi 0.7-2 2 -> 4
 extra/jemalloc 1:5.0.1-3 3 -> 4
 extra/libbytesize 1.0-1 1 -> 2
 extra/llvm-libs 5.0.1-1 1 -> 2
 extra/php 7.2.1-1 1 -> 3
 extra/php-apache 7.2.1-1 1 -> 3
 extra/php-gd 7.2.1-1 1 -> 3
 extra/php-intl 7.2.1-1 1 -> 3
 extra/python 3.6.4-1 1 -> 2
 extra/python2 2.7.14-1 1 -> 2
 extra/transmission-cli 2.92-7 7 -> 8
 extra/transmission-gtk 2.92-7 7 -> 8
 extra/wxgtk2 3.0.3.1-10 10 -> 11
 extra/wxgtk-common 3.0.3.1-10 10 -> 11
 community/gtk-engine-murrine 0.98.2-2 2 -> 3
 community/ristretto 0.8.2-1 1 -> 2
 community/tigervnc 1.8.0-3 3 -> 4
 community/wxpython 3.0.2.0-5 5 -> 6
 aur/bcg729 1.0.4-1 1 -> 2

==> Mise à jour des logiciels (nouvelle version) :
 core/ca-certificates-mozilla 3.34.1-1 -> 3.35-1
 core/coreutils 8.28-1 -> 8.29-1
 core/cryptsetup 2.0.0-5 -> 2.0.1-1
 core/gcc 7.2.1+20171224-2 -> 7.2.1+20180116-1
 core/gcc-libs 7.2.1+20171224-2 -> 7.2.1+20180116-1
 core/gdbm 1.13-1 -> 1.14.1-1
 core/glib2 2.54.3-2 -> 2.54.3+2+g94b38beff-1
 core/gnutls 3.5.16-1 -> 3.5.17-1
 core/lib32-gcc-libs 7.2.1+20171224-2 -> 7.2.1+20180116-1
 core/libmpc 1.0.3-2 -> 1.1.0-1
 core/libsystemd 236.0-3 -> 236.81-1
 core/libtasn1 4.12-2 -> 4.13-1
 core/linux-firmware 20171206.fdee922-1 -> 20180119.2a713be-1
 core/linux-lts 4.9.76-1 -> 4.9.78-1
 core/linux-lts-headers 4.9.76-1 -> 4.9.78-1
 core/mpfr 3.1.6.p1-1 -> 4.0.0-1
 core/nspr 4.17-1 -> 4.18-1
 core/nss 3.34.1-1 -> 3.35-1
 core/sqlite 3.21.0-1 -> 3.22.0-1
 core/sudo 1.8.21.p2-1 -> 1.8.22-1
 core/systemd 236.0-3 -> 236.81-1
 core/systemd-sysvcompat 236.0-3 -> 236.81-1
 core/tzdata 2017c-1 -> 2018c-1
 extra/bind 9.11.2-3 -> 9.11.2.P1-1
 extra/bind-tools 9.11.2-3 -> 9.11.2.P1-1
 extra/chromaprint 1.4.2-1 -> 1.4.3-1
 extra/chromium 63.0.3239.132-3 -> 64.0.3282.119-1
 extra/enchant 2.1.2-3 -> 2.2.1-1
 extra/git 2.15.1-2 -> 2.16.1-1
 extra/imagemagick 7.0.7.21-1 -> 7.0.7.22-1
 extra/libmagick 7.0.7.21-1 -> 7.0.7.22-1
 extra/libraqm 0.3.0-2 -> 0.4.0-1
 extra/librsvg 2:2.42.0-1 -> 2:2.42.1-1
 extra/libwacom 0.26-1 -> 0.27-1
 extra/libzip 1.3.0-1 -> 1.3.2-1
 extra/ocl-icd 2.2.11-1 -> 2.2.12-1
 extra/rsync 3.1.2-8 -> 3.1.3pre1-1
 extra/webkit2gtk 2.18.5-1 -> 2.18.6-1
 extra/wget 1.19.2-1 -> 1.19.4-1
 extra/xfce4-timer-plugin 1.6.0-4 -> 1.7.0-1
 community/fltk 1.3.4-2 -> 1.3.4.2-2
 community/gufw 17.10.0-1 -> 18.04.0-1
 community/pigz 2.3.4-1 -> 2.4-1
 community/python-psutil 5.4.1-1 -> 5.4.3-1
 community/teamspeak3 3.1.7-2 -> 3.1.8-1
 community/xfce4-whiskermenu-plugin 1.7.4-1 -> 1.7.5-1
 multilib/lib32-systemd 236.0-1 -> 236.81-1
 aur/adminer 4.3.1-1 -> 4.5.0-1
 aur/lib32-gsm 1.0.14-1 -> 1.0.17-1

Fin programmée de la passerelle SIP

Vers le 12 février le numéro de la passerelle SIP sera perdu sauf si je loue ce numéro. Jusqu’ici cette passerelle ne me coûtait absolument rien si ce n’est quelques ressources sur le serveur.
A partir du 12 février il me sera demandé 49€ pour conserveur ce numéro. Je dois être à peu près le seul à utiliser cette passerelle alors je ne compte pas payer pour cela. Si vous connaissez un fournisseur SIP qui offre un numéro géographique non surtaxé je suis preneur.

Mises à jour du 14 janvier 2017 ~ 19:45

==> Nouvelle révision des paquets :
 core/cryptsetup 2.0.0-2 2 -> 5
 core/gcc 7.2.1+20171224-1 1 -> 2
 core/gcc-libs 7.2.1+20171224-1 1 -> 2
 core/lib32-gcc-libs 7.2.1+20171224-1 1 -> 2
 core/libsystemd 236.0-2 2 -> 3
 core/openssh 7.6p1-1 1 -> 2
 core/systemd 236.0-2 2 -> 3
 core/systemd-sysvcompat 236.0-2 2 -> 3
 extra/chromium 63.0.3239.132-2 2 -> 3
 extra/ffmpeg 1:3.4.1-1 1 -> 3
 extra/gst-plugins-bad 1.12.4-1 1 -> 2
 extra/libcdio-paranoia 10.2+0.94+2-1 1 -> 2
 extra/libupnp 1.6.24-1 1 -> 2
 extra/wxgtk2 3.0.3.1-9 9 -> 10
 extra/wxgtk-common 3.0.3.1-9 9 -> 10
 community/fltk 1.3.4-1 1 -> 2
 community/mediastreamer 2.16.1-1 1 -> 2
 multilib/lib32-acl 2.2.52-2 2 -> 3

==> Mise à jour des logiciels (nouvelle version) :
 core/archlinux-keyring 20171213-1 -> 20180108-1
 core/e2fsprogs 1.43.7-1 -> 1.43.8-1
 core/glib2 2.54.2-2 -> 2.54.3-2
 core/linux-lts 4.9.75-1 -> 4.9.76-1
 core/linux-lts-headers 4.9.75-1 -> 4.9.76-1
 core/netctl 1.14-1 -> 1.15-1
 core/xfsprogs 4.13.1-1 -> 4.14.0-1
 extra/freetype2 2.8.1-1 -> 2.9-1
 extra/gtk2 2.24.31-1 -> 2.24.32-1
 extra/gvfs 1.34.1+8+g091ac25d-1 -> 1.34.1+11+gad63dfb7-1
 extra/imagemagick 7.0.7.20-1 -> 7.0.7.21-1
 extra/intel-ucode 20171117-1 -> 20180108-1
 extra/libcdio 0.94-2 -> 2.0.0-1
 extra/libmagick 7.0.7.20-1 -> 7.0.7.21-1
 extra/librsvg 2:2.41.2-1 -> 2:2.42.0-1
 extra/libsoup 2.60.2-1 -> 2.60.3-1
 extra/libsrtp 1:1.5.4-2 -> 1:2.1.0-1
 extra/libwebp 0.6.0-1 -> 0.6.1-1
 extra/libx264 2:148.20170521-1 -> 2:152.20171224-1
 extra/perl-uri 1.72-2 -> 1.73-1
 extra/webkit2gtk 2.18.4-1 -> 2.18.5-1
 community/arc-solid-gtk-theme 20170302-4 -> 20180114-1

==> Nouveau paquet :
 core/argon2 20171227-3 (requis par cryptsetup)

Mises à jour du 7 janvier 2017 ~ 10:45

==> Nouvelle révision des paquets :
 core/binutils 2.29.1-1 1 -> 2
 core/cryptsetup 2.0.0-1 1 -> 2
 core/glibc 2.26-8 8 -> 10
 core/lib32-glibc 2.26-8 8 -> 10
 extra/bind 9.11.2-2 2 -> 3
 extra/bind-tools 9.11.2-2 2 -> 3
 extra/vim 8.0.1415-1 1 -> 2
 extra/vim-runtime 8.0.1415-1 1 -> 2

==> Mise à jour des logiciels (nouvelle version) :
 core/gcc 7.2.1-2 -> 7.2.1+20171224-1
 core/gcc-libs 7.2.1-2 -> 7.2.1+20171224-1
 core/json-c 0.12.1-1 -> 0.13-1
 core/lib32-gcc-libs 7.2.1-2 -> 7.2.1+20171224-1
 core/libnghttp2 1.28.0-1 -> 1.29.0-1
 core/linux-api-headers 4.12.7-1 -> 4.14.8-1
 core/linux-lts 4.9.73-1 -> 4.9.75-1
 core/linux-lts-headers 4.9.73-1 -> 4.9.75-1
 core/nano 2.9.1-1 -> 2.9.2-1
 core/zstd 1.3.2-1 -> 1.3.3-1
 extra/boost-libs 1.65.1-2 -> 1.66.0-1
 extra/chromium 63.0.3239.108-2 -> 63.0.3239.132-2
 extra/geoip-database 20171205-1 -> 20180102-1
 extra/imagemagick 7.0.7.16-1 -> 7.0.7.20-1
 extra/libatomic_ops 7.4.8-1 -> 7.6.2-1
 extra/libmagick 7.0.7.16-1 -> 7.0.7.20-1
 extra/librsvg 2:2.40.20-1 -> 2:2.41.2-1
 extra/php 7.2.0-2 -> 7.2.1-1
 extra/php-apache 7.2.0-2 -> 7.2.1-1
 extra/php-gd 7.2.0-2 -> 7.2.1-1
 extra/php-intl 7.2.0-2 -> 7.2.1-1
 extra/protobuf 3.5.0.1-1 -> 3.5.1.1-1
 extra/python-setuptools 1:38.2.5-1 -> 1:38.4.0-1
 extra/re2 20171201-1 -> 20180101-1
 extra/xterm 330-1 -> 331-1

Nouveaux inscrits

Les nouveaux inscrits doivent poster un billet pour se présenter sans quoi leur compte sera effacé. Le fait de s’inscrire permet de poster des billets ou de rédiger des articles. Il est inutile de s’inscrire pour consulter le site.
Les nouveaux billets des nouveaux membres seront bien évidement modéré dans un premier temps et n’apparaîtrons pas sur le site tout de suite. Après quelques billets le statu du compte passera en Auteur et l’utilisateur pourra poster ses billets sans avoir à subir la modération.

Bonjour tout le monde !

Bienvenue sur le nouveau site de SRDL. Le serveur de radiocommunication de loisir. L’ancien site propulsé par Dotclear à été détruit suite à une grotesque erreur de ma part. J’espère que je ne referai pas d’erreur de la sorte dans l’avenir.
Le nouveau site est propulsé par WordPress qui permet à priori beaucoup plus de possibilités. J’aimerai notamment qu’il y’ait des contributeurs pour poster des articles.
Le top serait que tout le monde soit ici et non plus sur le groupe Facebook. Ce groupe deviendrait juste une page reflétant de l’activité du site. C’est beau de rêver.